Win engine outage

Incident Report for Vivo Gaming

Resolved

Win engine is now working as intended
Posted Apr 25, 2026 - 04:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 25, 2026 - 03:24 UTC
This incident affected: Backend Applications (Payout Engines).